Loading...

MT4+ servers update

Dear traders,

We would like to inform you about a recent change concerning MT4+. After July 1, 2019 all MetaTrader 4 platforms below version 1170 will not be supported. Therefore, old terminal versions will not be able to connect to our trading servers.

We recommend you avoid any problems by updating your MetaTrader 4 terminals to the latest build 1170 or find the latest download links in your My JFD area.

Thank you for being part of the trading experience with JFD!